CocoaPods:正常にライブラリのアップデートができない

Xcode13への切り替えにあたり、既存プロジェクトで使用しているライブラリをアップデートする必要がありました。CocoaPodsによるアップデートをしようとしたら、以下のようなエラーが発生して正常にアップデートできなかったので、その際の解決方法をご紹介します。

[!] Unable to find a specification for `ライブラリ名`
You have either:
 * mistyped the name or version.
 * not added the source repo that hosts the Podspec to your Podfile.

環境

Xcode:13.1
CocoaPods:1.11.2

解決方法

pod repo update

一度Pod内のライブラリを削除して、再度インストールし直すことで解決できました。 これはいくつかある解決方法の一つに過ぎません。私はこれで済みましたが、これでも解決できない場合は今回参考にさせていただいた記事をご確認ください。

参考記事

CocoaPodsが正常にアップデートできない時の対処方法 | ニートに憧れるプログラム日記